Entering Data in the Spreadsheet


Creating a New File

 

To begin a new spreadsheet, click File > New or click the New File tool button.


 

The first time you create a new spreadsheet, it will usually look like this:

 

Note that columns E and F are hidden. To show all columns, click Tools > Options:

 

Which will show the Spreadsheet Options dialog box.

To show all columns, check all check boxes under Show Columns.

 

 

Now all columns are visible:

 

Dataset Type

 

The text in cell A1 indicates the type of dataset. While this entry is not essential, it does affect automatic data entry with taxa lookup files (see below). Select the dataset type by clicking the cell and selecting from the dropdown menu:

 

These dataset types are defined in the Neotoma Paleoecology Database.

 

 

The default dataset type is Pollen, but your spreadsheet will open with the dataset type of the last file you saved. 

 

Variables

 

In a Tilia spreadsheet, rows are variables and columns are samples. Variables comprise several components: Code, Name, Element, Units, Context, Taphonomy, and Group. For making stratigraphic diagrams, only the Code and Name are required; however, Group is usually very useful. Variables in the Neotoma Paleoecology Database also require Element and Units

 

 

Context and Taphonomy are used less often, and will be discussed later, so these columns will now be hidden.

 

 

Name is the name of the taxon.

 

Code is a unique code for each taxon. Codes can be anything you want; the only requirement is that they be unique within the spreadsheet. The codes shown in this example are those used in the Neotoma Paleoecology Database.

 

Element is the element identified. As this is a pollen dataset, most elements will be pollen or spore. However, others are possible, such as stomate. Other dataset types may have many kinds of elements. For example, plant macrofossil datasets may have leaf, needle, seed, bud scale, and so on. The elements may optionally appear in a diagram, e.g. Picea needle, Picea seed.

 

Units are the measurement units for the variable. NISP = Number of Identified Specimens, in other words, a count.

 

Group is a code for any grouping scheme. The codes shown here are the default codes for pollen datasets from the Neotoma Paleoecology Database:

 

 

Code Group
TRSH Trees and Shrubs
PALM Palms
MANG Mangroves
UPHE Upland Herbs
SUCC Succulents
VACR Vascular Cryptogams
UPBR Upland Bryophytes
AQVP Aquatic Vascular Plants
AQBR Aquatic Bryophytes
FUNG Fungi
ALGA Algae
UNID Unknown and Indeterminable

 

It is not necessary to use these codes; you may use any codes you like. However, if these codes are suitable for your data, they make calculation of percentages somewhat easier.

 

Samples

 

Samples begin in column H. Row 1 is for sample depths. Row 2 is for sample names. For stratigraphic diagrams, you must have depths. Sample names are optional, and they may be shown on the diagram. Surface samples commonly have names. The example below is a Pollen surface sample dataset. The depths are pseudo depths that will set the spacing between samples on a diagram.

 

 

Data

  

The actual data begin in cell H3. In all the examples so far, zero values can be represented by a 0 in the cell or by leaving the cell blank. However, if cells are left blank, you will be asked if they should be converted to zero for the diagram. In some cases, blank cells may indicate no data rather than a zero values. For example, if pollen and loss-on-ignition (LOI) data are in the same spreadsheet, some sample depths may have LOI data and not pollen data, in which case the pollen cells should be left blank for the sample depths with only LOI data, and zero values should be entered for the pollen samples. 

 

Variable Lookup Files

  

Taxa names may be entered directly, copied and pasted from another spreadsheet, or chosen from an external lookup file. Tilia is distributed with a number of variable lookup files, which may be updated periodically from the Neotoma Paleoecology Database. To open a lookup file, either click Tools > Variable Lookup or click the Variable Lookup tool button.

 


 

Which will show the Variable Lookup Files dialog box:

 

 

You can select which lookup file by selecting the Browse… button. By default, the variable lookup files are stored in the directory:

 

C:\Users\[User Name]\AppData\Local\Tilia\Lookup

 

The lookup files all have the .xml extension, e.g. NeotomaPollenTaxa.xml

 

The modifiers (Element, Units, etc.) are stored in a separate file, which ordinarily would always be the default file name NeotomaVariableModifiers.xml.

 

After a variable lookup file is opened, taxa names can be selected from the dropdown list. You can also start typing a name, and the matching names will appear. If a name is not in the list, you can type in a new name.

 

 

The names in the lookup file are from the Neotoma Paleoecology Database. Thus, the NeotomaPollenTaxa.xml lookup file has all the names that appear in Neotoma pollen datasets.

 

If you select a taxon from the dropdown list, the Code and default Group will be automatically entered. If the taxon has only one element in the database, then it will also be entered. Otherwise, the element can also be selected from a dropdown list:

 

 

The elements listed are those currently in Neotoma for the pollen dataset type. The more… selection indicates there are more  elements in another dataset type, in this case in plant macrofossil datasets. If you click more…, those additional elements will appear.

 

Units can also be selected from a dropdown list. All units for the dataset type will be listed:

 

 

Updating Variable Lookup Files

 

To update your local Tilia lookup file from Neotoma, click Neotoma > Lookup > New Taxa Lookup File.

 

 

Which will show the Write New Taxa Lookup File dialog box:

 

Check the lookup file you want to update, which in this example is the pollen lookup. Click the Next button.

A panel will appear on the right with the taxa groups that will be included in this lookup file. This list cannot be edited; it's solely informative. Click the Finish button to write the new file. You will be asked whether you want to replace your existing lookup file. Ordinarily, you would click Yes.

 

Importing Data from Excel

 

Data may be imported from Excel by either opening an .xls file (not .xlsx) or by copying and pasting. To open an .xls file, click File > Open and in the lower right corner of the open file dialog box, select Microsoft Excel Workbook (*.xls) to show the available files. Ensure that the file is not open in Excel before attempting to open in Tilia.

 

 

Tilia reads the Excel file cell for cell. Hidden columns in Tilia will still be recognized in the Excel file. Consequently, the Excel file must be formatted exactly the same as the Tilia file, as below:

 

 

The cells in blue will be ignored when Tilia reads the worksheet. You will be prompted as to which worksheet you want to import.

 

In general, it is easier to copy and paste data from Excel rather than read the file, although you may need to transpose the worksheet first so that columns are samples and rows are variables. Simply copy and paste the taxa names to column B starting in cell A3, the sample depths to row 1 staring in cell H1, and the data starting in cell H3. Copying and pasting is the only way to import data from an .xlsx file, other than saving to a .xls file.